QuickBooks 2015 Announced – Important System Requirements

QuickBooks 2015 Announced – Important System Requirements

QuickBooks 2015 - What's New?
QuickBooks 2015 was announced and release to Certified QuickBooks ProAdvisors yesterday - which means that end users will have it made available to them either the end of this month or the beginning of October; there are no firm dates as of yet. Before I start talking about some of the new features that I think are ok, good, or great - I want to address system requirements, which I feel is very important. QuickBooks 2015 does not support Windows XP As  Certified QuickBooks ProAdvisor and 3rd party desktop developer, I still have clients and customers using Windows XP and I'm betting that you do too - and that's why I think this is important. Also, if you are running QuickBooks 2012 and need payroll or access to online banking…
Read More